iPod School

Tem um iPhone 4 com ultrasn0w e quer atualizar seu iOS?

Arthur FerreiraArthur Ferreira

Muitas pessoas compraram o iPhone 4 em lugares como os EUA e dependem do carrier unlock , ou seja, do ultrasn0w. O problema é o seguinte, o ultrasn0w só funciona na baseband 01.59.00, que é a dos iOSs 4.0.x ou 4.0 apenas. Para saber sua baseband, vá em Ajustes>Geral>Sobre e veja o firmware do modem.

AVISO : ESTE TUTORIAL SERVE APENAS PARA IPHONE 4. NÃO TENTE EM OUTROS DEVICES.

Preservando a baseband

ATENÇÃO : Este tutorial requer um certo nível de conhecimento de jailbreaking e hacktivating. O iPodSchool não dá nenhuma garantia de funcionamento e não se responsabiliza por qualquer erro ou dano ocorridos.

Vamos começar!

Primeiro vamos usar o famoso TinyUmbrella. Você pode baixá-lo no site oficial, windows, mac e java.

  1. Baixe o TinyUmbrella para seu sistema.
  2. Baixe o último greenpois0n. (RC5 3 – Mirror-OSX)
  3. Abra o TinyUmbrella
  4. Conecte seu iPhone 4 e salve seu SHSH. (Tenha certeza que o SHSH do iOS 4.2.1 foi salvo, caso não, pare de tentar seguir esse tutorial).
  5. Clique em Start TSS Server.
  6. Abra o iTunes
  7. Abra seu iPhone 4 no iTunes (Página do aparelho).
  8. Segure Shift(windows) / Option(Mac), clique em restore e selecione o ipsw do iOS 4.2.1. (Download do iOS).
  9. Você deverá receber o erro 1013, clique nos OKs e feche o iTunes.
  10. Com seu iPhone conectado e com a tela de recovery, entre em DFU : segure Home+Power até sua tela ficar preta, então após 2 segundos solte o Power e continue segurando Home até seu aparelho entrar em DFU. Caso dê errado, seu aparelho tentará dar boot e mostrará a tela de recovery então recomece o passo 10.
  11. Abra o greenpois0n e clique em jailbreak.
  12. Após terminar, será mostrado uma mensagem de conclusão, clique “complete!”.
  13. Faça o dowload do redsn0w 0.9.7b6 (mac).
  14. Selecione o firmware 4.2.1 do iPhone 4 no redsn0w, selecione para apenas intalar o Cydia e siga as instruções para a instalação. Após este passo pode deletar o Loader da sua SpringBoard e instalar o ultrasn0w.

Você pode ver um vídeo no youtube desse tutorial.

Até a próxima.

Comecei no blog há 4 anos, tudo começou com a tarefa de programar o FastHelp. Tudo deu certo e hoje faço parte da equipe. Não apareço muito no blog por não exercer a função de redator. Atualmente possuo um iPhone 5 16GB(BR).

  • Klaudio

    Today we’re pleased to announce our free carrier unlock for iPhone3G/3GS owners with a baseband later than 05.13.04.  The unlock for that baseband exploited the AT+XAPP command, thanks to a crash initially discovered by @sherif_hashim (@Oranav also found this crash).  So what hole are we exploiting today, since Apple closed that AT+XAPP hole?  Well, we’re exploiting the exact same hole!

  • Camila

    Isso significa q se eu comprei um iPhone 4 nos EUA após esse processo ele ira funcionar no Brasil??

  • Lucas

    Eh mais ou menos isso camila, vc podera colocar todos os chips que eles funcionarao.

    Mas tem que conferir o baseband

    • Camila

      Ou seja se for outro baseband. Tipo não for o 01.59.00 o processo acima não ira funcionar?? Preciso de uma ajuda, eu estou no EUA quero comprar o iPhone mais os vendedores da Apple me falaram q nao funciona no Brasil. Agora com esse processo eu devo comprar ou nao??

      • Esse processo serve apenas para iPhones comprados na época da 4.0 ou 4.0.x agora não adianta mais, pois a baseband já vem atualizada. 🙂

        • Camila

          Ou seja, nao compro??

          • rodrigo

            Infelizmente do tio San não, Camila !!!

  • Pingback: Tweets that mention Tem um iPhone 4 com ultrasn0w e quer atualizar seu iOS? | iPod School -- Topsy.com()

  • Essarts

    (Tenha certeza que o SHSH do iOS 4.2.1 foi salvo, caso não, pare de tentar seguir esse tutorial).Está correto isso?Não é o FW que vc ta usando no momento?No meu caso o 4.01???

    • rodrigo

      é voce esta certo Essarts !!! Vc tem apenas que atualizar o FW do iphone e fazer o jailbreak.

      LEMBRANDO,JAILBREAK NÃO É DESBLOQUEIO !!!

      Vlw !!

    • Mas tem que ter o SHSH do seu fw atual E do 4.2.1

  • Rebecca

    Olá, tenho um iphone 4 dos EUA meu iOS é o 4.0.1 e minha baseband é a 01.59.00. Gostaria de saber se alguem conseguiu manter a baseband? E isso é realmente confiavel?

    • Sim dá pra fazer. Siga esse tuto a risca, testei em 2 iPhones 4 de amigos e deu certo.

  • Victor Murad

    Sério que só funciona no iPhone 4? =/

  • Anderson

    Estou achando quem tem um IPhone 4 4.1 com BB acima de 01.59 tomou fumo,não vai ter desbloqueio,pois já lançaram 2 Jailbreak e nenhum Unlock!!!Jailbreak 4.1 e 4.2.1

  • Tonico

    estou esperando o unlock o utrasnow 2.2 a 5 meses e nada

    • Pedro

      Quem mando atualizar?da nisso né… Atualiza sem nem mesmo espera pra ver se já tem unlock

  • Arthur

    pessoal, eu ia mandar trazer um iphone 4 pra mim semana que vem dos EUA, e agora? compro ou nao?

  • Poderia atualizar esse tutorial? Ele continua valendo para o 4.3.3? eu tenho 2 iPhones 4 (4.0.1 – 1.59.00) comprados nos USA (COM ULTRASN0W) e preciso atualizar o firmware, pois diversos apps que quero usar não funcionam na versão 4.0.1. Portanto peço que se possível, dê uma atualizada para me ajudar a atualizar meus iPhones… Abração.

  • Essarts

    ta valendo para o 4.3.3?